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1 WPROWADZENIE

1 Wprowadzenie

�wiczenie prezentuje podstawowe narz¦dzia do pracy z mikrokontrolerem �rmy ST. Jest to
STM32CubeMX [3], [8] � aplikacja pozwalaj¡ca w wygodny sposób na przygotowanie podstawowej kon-
�guracji peryferiów mikrokontrolera poczynaj¡c od GPIO, a ko«cz¡c na middleware �rm trzecich, jak
FreeRTOS. Jest ono integraln¡ cz¦±ci¡ programu STM32CubeIDE lub wyst¦puje osobno jako samodzielna
aplikacja. Ponadto, oprogramowanie pozwala na kon�guracj¦ cz¦stotliwo±ci taktowania rdzenia w trybie
r¦cznym lub póªautomatycznym. Do rozwoju oprogramowania dla mikrokontrolera wykorzystywane b¦-
dzie ±rodowisko STM32CubeIDE. �rodowisko to bazuje na zmody�kowanej wersji oprogramowania Atollic
TrueStudio for STM32. Jest to ±rodowisko oparte o popularne IDE � Eclipse, jednak»e zostaªo ono od-
powiednio skon�gurowane do pracy z ukªadami �rmy ST.

Jako zestaw ewaluacyjny wykorzystana zostanie pªytka deweloperska NUCLEO-L476RG [4], [5]. Po-
siada ona mikrokontroler STM32L476RGT6 [1], szerszy opis tej rodziny mikrokontrolerów mo»na znale¹¢
w [9].

Zdj¦cia pªytki ewaluacyjnej zostaªy przedstawione poni»ej.

Rysunek 1: Zestaw ewaluacyjny NUCLEO-L476RG
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2 OPIS �WICZENIA

Rysunek 2: Zestaw ewaluacyjny NUCLEO-L476RG w opakowaniu

2 Opis ¢wiczenia

�wiczenie ma za zadanie zaznajomi¢ studenta z obsªug¡ oraz wykorzystaniem przedstawionego opro-
gramowania: kon�guracja peryferiów, dobór cz¦stotliwo±ci pracy ukªadu, automatyczne generowanie kodu.
Ponadto ¢wiczenie, obejmuje zakres zwi¡zany z obsªug¡ GPIO na przykªadzie diody LED (cyfrowe wyj-
±cie) oraz przycisku (cyfrowe wej±cie).
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3 TWORZENIE PROJEKTU W STM32CUBEIDE

3 Tworzenie projektu w STM32CubeIDE

Nowy projekt mo»na utworzy¢ na kilka sposobów. Jednym z nich jest wybranie odpowiedniej pozycji
z gªównego menu (File → New → STM32 Project). Wówczas pojawi si¦ okno, które pozwala na wybór
jednostki, czy wybór pªytki testowej. Kon�guracja projektu od tego momentu jest bardzo podobna do
kon�guracji projektu w STM32CubeMX z kilkoma ró»nicami. Po wybraniu ukªadu, b¡d¹ pªytki deweloper-
skiej nale»y nada¢ nazw¦ projektu, tak jak to pokazano na rysunku 3. Pozostaªe opcje powinny by¢ bez
zmian, to jest wybrany j¦zyk ustawiony na C, docelowy plik binarny ustawiony an wykonywalny, a typ
projektu to STM32Cube.

Rysunek 3: Wybór nazwy projektu

Po kon�guracji podstawowych ustawie« projektu nale»y przej±¢ do nast¦pnego okna (Rys. 4). Na tym
etapie nale»y zaakceptowa¢ domy±ln¡ kon�guracj¦.
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3 TWORZENIE PROJEKTU W STM32CUBEIDE

Rysunek 4: Kon�guracja bibliotek projektu

Po przej±ciu dalej, pojawi si¦ komunikat z pytaniem, czy zainicjalizowa¢ dost¦pne peryferia (Rys.
5). Nale»y zaakceptowa¢ akcj¦ i oczekiwa¢ na zako«czenie dziaªa« przez ±rodowisko. W tym momencie
program mo»e wymaga¢ pobrania dodatkowych bibliotek z Internetu, których rozmiar to okoªo 700MB.

Rysunek 5: Inicjalizacja wybranych peryferiów na pªytce deweloperskiej

W odró»nieniu do aplikacji STM32CubeMX generowanie kodu odbywa si¦ z poziomu programu
STM32CubeIDE. W tym celu nale»y wybra¢ Project → Generate Code, tak jak to zostaªo pokazane na
rysunku 6.

Wszystkie prawa zastrze»one Wojciech Domski © 2017-2018, edu.domski.pl 5

edu.domski.pl


3.1 Wgrywanie programu 3 TWORZENIE PROJEKTU W STM32CUBEIDE

Rysunek 6: Generowanie kodu w aplikacji STM32CubeIDE

Budowanie projektu odbywa si¦ poprzez wybranie z menu opcji Project → Build All. Po zbudowaniu
projektu, je±li skompiluje si¦ on bez ostrze»e«, w katalogu projektu pojawi si¦ folder Debug. To w nim
zostan¡ umieszczone zbudowane obrazy �rmware'u (*.bin, *.hex).

Uwaga! Podczas regeneracji kodu mo»e zaj±¢ konieczno±¢ wyczyszczenia oraz przebudowania pro-
jektu. Aby wyczy±ci¢ projekt nale»y z menu wybra¢ projekt, a nast¦pnie wyczy±¢ (Project → Clean)

3.1 Wgrywanie programu

Wgranie programu do mikrokontrolera jest mo»liwe bezpo±rednio z poziomu ±rodowiska programistycz-
nego. W tym celu nale»y wybra¢ z menu Run → Run. Pierwsze wywoªanie akcji uruchomienia spowoduje
otwarcie okna z kon�guracj¡ (rys. 7). Domy±lnie wybrane ustawienia s¡ wystarczaj¡ce do prawidªowego
zaprogramowania ukªadu.
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3.2 Przydatne informacje 3 TWORZENIE PROJEKTU W STM32CUBEIDE

Rysunek 7: Wgrywanie aplikacji w programie STM32CubeIDE

Ka»de kolejne wywoªanie tej akcji spowoduje wybranie ostatniej kon�guracji. Dost¦p do listy dost¦p-
nych kon�guracji jest równie» dost¦pny z poziomu menu Run → Run Con�gurations . . .. Uruchamianie
sesji debugowania jest niemal identyczne, ró»ny si¦ ono jedynie wyborem odpowiedniej akcji (Run →
Debug).

Uwaga! Aby mo»liwe byªo poprawne uruchomienie aplikacji musz¡ by¢ speªnione nast¦puj¡ce wa-
runki.

1. Aplikacja zostaªa zbudowana bez bª¦dów.

2. Do komputera zostaª podª¡czony programator (Pªytka testowa posiada ju» wbudowany programa-
tor).

3. Wszystkie zworki na pªytce testowej musz¡ by¢ we wªa±ciwej pozycji.

W przeciwnym wypadku mog¡ pojawi¢ si¦ bª¦dy.

1. Kon�guracja uruchomieniowa nie mo»e odnale¹¢ zbudowanego programu.

2. Programator nie jest podª¡czony do komputera.

3. Mikrokontroler docelowy nie jest odnaleziony najprawdopodobniej przez niewªa±ciw¡ kon�guracj¦
zworek na pªytce testowej.

3.2 Przydatne informacje

STM32CubeMX dostarcza kilku przydatnych opcji podczas pisania oprogramowania. Pierwsz¡ z nich jest
automatyczne podpowiadanie nazw funkcji, zmiennych, itp. W tym celu nale»y wpisa¢ pocz¡tek nazwy
funkcji Ctrl + Spacja. Wówczas wy±wietl¡ si¦ dopasowania, które odpowiadaj¡ aktualnie wprowadzo-
nemu fragmentowi funkcji, zmiennej (Rys. 8).
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3.2 Przydatne informacje 3 TWORZENIE PROJEKTU W STM32CUBEIDE

Rysunek 8: Podpowiadanie nazw

Innym przydatnym narz¦dziem jest podpowiadanie listy argumentów funkcji. Przykªad okazano na
rysunku 9). Aby wy±wietli¢ podpowied¹ nale»y znale¹¢ si¦ w li±cie argumentów funkcji (pomi¦dzy okr¡-
gªymi nawiasami) i wcisn¡¢ kombinacj¦ klawiszy Ctrl + Shift + Spacja. Aktualnie aktywny argument
jest pod±wietlany.

Rysunek 9: Podpowiadanie nazw

Podczas gdy chcemy przeª¡czy¢ si¦ z pliku ¹ródªowego na odpowiadaj¡cy plik nagªówkowy wystar-
czy wykorzysta¢ kombinacj¦ klawiszy Ctrl + Tab. Skrót ten umo»liwia naprzemienne przeª¡czanie si¦
pomi¦dzy powi¡zanymi plikiem nagªówkowym oraz plikiem ¹ródªowym.

Je±li zajdzie potrzeba przej±cia do de�nicji funkcji mo»na wykorzysta¢ przycisk funkcyjny F3. Po
najechaniu kursorem na funkcj¦, której de�nicja jest interesuj¡ca wystarczy wcisn¡¢ klawisz F3, a ±rodo-
wisko programistyczne automatycznie odnajdzie de�nicj¦. Mo»liwy jest powrót do poprzedniego miejsca
w programie przez wci±ni¦cie kombinacji klawiszy Alt + ←
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4 PRACA Z NARZ�DZIEM STM32CUBEMX

4 Praca z narz¦dziem STM32CubeMX

4.1 Przygotowanie projektu w programie STM32CubeMX

Nale»y uruchomi¢ program STM32CubeMX. Nast¦pnie wybieramy nowy projekt (New Project). Operacja
ta mo»e chwil¦ potrwa¢, gdy» aplikacja sprawdza dost¦pno±¢ nowych produktów. W oknie nowego projektu
wybieramy odpowiedni¡ pªytk¦ ewaluacyjn¡, aby to zrobi¢ nale»y wybra¢ zakªadk¦ wyboru pªytki (Board
Selector), a nast¦pnie wybra¢ typ pªytki (Type) oraz seri¦ mikrokontrolera (MCU Series), Nucleo64
oraz STM32L4, odpowiednio. Po zredukowaniu liczby dost¦pnych zestawów deweloperskich wybieramy
NUCLEO-L476RG z listy (Rys. 10).

Rysunek 10: Okno z wyborem zestawu ewaluacyjnego NUCLEO-L476RG

Po klikni¦ciu przycisku Start Project zostaniemy zapytani, czy chcemy zainicjalizowa¢ peryferia do-
my±lnymi ustawieniami. Wybór przycisku Tak Yes spowoduje, »e peryferia takie, jak zegar LSI, czy
USART zostan¡ skon�gurowane domy±lnie. Wybranie opcji Nie No nie spowoduje przeprowadzenia do-
my±lnej kon�guracji. W obu przypadkach wyj±cia dla diody LED oraz dla przycisku b¦d¡ odpowiednio
skon�gurowane. Po tym etapie powinien pojawi¢ si¦ czysty projekt z wst¦pnie skon�gurowanymi wyj-
±ciami mikrokontrolera, jak na rysunku 11.
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4.1 Przygotowanie projektu w programie STM32CubeMX4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 11: Okno przedstawiaj¡ce pocz¡tkow¡ kon�guracj¦ mikrokontrolera dla pªyty ewaluacyjnej
NUCLEO-L476RG

Piny pod±wietlone na kolor zielony (PC13 i PA5) oznaczaj¡, »e te porty mikrokontrolera zostaªy skon-
�gurowane poprawnie. Piny pod±wietlone na kolor pomara«czowy oznaczaj¡, »e funkcjonalno±¢ portu
zostaªa wybrana lecz nie zostaª on jeszcze w peªni skon�gurowany, jak np. PA2 oraz PA3, które wy-
korzystywane s¡ do komunikacji za pomoc¡ portu szeregowego, jednak»e sam port szeregowy (USART)
nie zostaª jeszcze skon�gurowany (chyba, »e wybrano automatyczn¡ inicjalizacj¦ peryferiów domy±lnymi
ustawieniami).

Uwaga! Warto zwróci¢ uwag¦ na nazwy poszczególnych pinów (ich etykiety), jakie s¡ widoczne w
widoku Pinout. Przykªadowo dla pinu PA5, do którego podª¡czona jest dioda LED zostaªa ustawiona
etykieta LD2 [green Led]. Podczas automatycznego generowania kodu opisanego w rozdziale 4.2 zostan¡
wykorzystane etykiety, które zostaªy nadane przez u»ytkownika do stworzenia przyjaznych de�nicji, któ-
rymi mo»na si¦ pó¹niej posªugiwa¢. De�nicje te znajduj¡ si¦ zwyczajowo w pliku Inc/main.h. Dla wy»ej
wspomnianego pinu PA5 zostan¡ utworzone poni»sze de�nicje:

1 #de f i n e LD2_Pin GPIO_PIN_5
2 #de f i n e LD2_GPIO_Port GPIOA

Mog¡ one pó¹niej zosta¢ wykorzystane do wywoªa« funkcji z biblioteki HAL, jak np. przeª¡czanie stanu
cyfrowego wyj±cia. Wówczas programista nie musi pami¦ta¢, do którego portu i numeru pinu przynale»y
dana nó»ka mikrokontrolera, a jedynie wystarczy wiedza na temat etykiety, jaka zostaªa do niej przypi-
sana. Jak wida¢ na przykªadzie napis znajduj¡cy si¦ w nawiasach kwadratowych jest pomijany w czasie
generacji de�nicji.

Do poprawnego dziaªania oprogramowanie STM32CubeMX wymaga poª¡czenia z Internetem. Jest to
spowodowane tym, »e pobierane s¡ aktualizacje produktów dost¦pnych w aplikacji. Je±li uruchamianie
narz¦dzia trwa zbyt dªugo mo»na wyª¡czy¢ sprawdzanie aktualizacji w menu programu. Wystarczy wybra¢
Help→ Updater settings ..., a nast¦pnie w zakªadce Updater Settings zaznaczy¢ opcj¦Manual checks oraz
No Auto-Refresh at Application start. Zostaªo to zaprezentowane na Rys. 12.
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4.1 Przygotowanie projektu w programie STM32CubeMX4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 12: Wyªaczenie automatycznego sprawdzania aktualizacji

4.1.1 Kon�guracja zegara

Wa»nym aspektem pracy mikrokontrolera jest kon�guracja cz¦stotliwo±ci pracy zegara. W ramach
tego ¢wiczenia nale»y zapozna¢ si¦ z informacjami, jakie s¡ dost¦pne w zakªadce kon�guracji zegara
(Clock Con�guration) (Rys. 13).
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4.2 Automatyczne generowanie kodu 4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 13: Zakªadka z kon�guracj¡ zegara dla caªego ukªadu

Z rysunku 13 mo»na wywnioskowa¢, jaka jest cz¦stotliwo±¢ pracy rdzenia oraz jakie jest jego ¹ródªo �
zidenty�kuj je i prze±led¹ ±cie»k¦ generowania zegara. Czy wykorzystywany jest do tego jaki± ukªad, je±li
tak, to jaka jest jego rola.

4.2 Automatyczne generowanie kodu

STM32CubeMX nie tylko pozwala na ªatw¡ kon�guracj¦ peryferiów mikrokontrolera, ale przede wszyst-
kim jest narz¦dziem do automatycznego generowania kodu. Przed przyst¡pieniem do generowania kodu
z projektu nale»y upewni¢ si¦, »e zostaª¡ zainstalowana biblioteka sterowników HAL dla rodziny mikro-
kontrolerów STM32L4. W tym celu nale»y wybra¢ z menu Help → Manage embedded software packages
oraz upewni¢ si¦, »e odpowiedni pakiet zostaª zainstalowany (b¦dzie posiadaª ikon¦ maªego zielonego
kwadratu). Na potrzeby laboratoriów nie jest wymagana instalacja najnowszej wersji biblioteki, je±li jest
taka dost¦pna (Rys. 14).
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4.2 Automatyczne generowanie kodu 4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 14: Zainstalowane biblioteki

Aby skon�gurowa¢ sposób w jaki kod zostanie wygenerowany nale»y u»y¢ kombinacji kombinacji
klawiszy Alt+P lub wybra¢ Project → Settings. W nowym oknie nale»y wpisa¢ potrzebne dane 15.

Rysunek 15: Kon�guracja projektu � ustawienia ogólne

Kon�guracj¦ nale»y rozpocz¡¢ od ustawienia zestawu narz¦dzi, IDE (Toolchain / IDE). Nale»y wybra¢
STM32CubeIDE. Dodatkowo opcja generowania projektu w gªównym drzewie katalogu (Generate Under
Root) powinna by¢ zaznaczona. Po wyborze IDE ustalamy nazw¦ projektu (Project Name), w tym przy-
padku jest to lab01 oraz wybieramy lokalizacj¦. Kolejnym etapem jest ustalenie, w jaki sposób b¦dzie
generowany sam kod. Przykªadowa kon�guracja zostaªa pokazana na rysunku 16.
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4.2 Automatyczne generowanie kodu 4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 16: Kon�guracja projektu � ustawienia generowania plików

Szczególn¡ uwag¦ nale»y zwróci¢ na grup¦ generowanych plików (Generated �les). Znajduj¡ si¦ tam
nast¦puj¡ce opcje:

1. Generate peripheral initialization as a pair of '.c/.h' �les per peripheral

2. Backup previously generated �les when re-generating

3. Keep User Code when re-generating

4. Delete previously generated �les when not re-gnerated

Pierwsza z nich powoduje, »e tworzona jest para plików (kod ¹ródªowy i nagªówek) dla ka»dego z peryfe-
rium. Opcja ta powinna by¢ wybrana. Jest ona szczególnie przydatna podczas pracy zespoªowej poniewa»
pozwala na fragmentacj¦ kodu i uªatwia jego utrzymanie oraz zarz¡dzanie. Drugie pole dotyczy tworzenia
kopii zapasowej plików, które b¦d¡ powtórnie generowane. Wówczas tworzony jest katalog backup do
wn¦trza, którego przenoszone s¡ pliki, do których nazwy dodawany jest czªon �.old�. Owy katalog jest
tworzony zarówno dla kartotek Src oraz Inc, w których przechowywane s¡ pliki ¹ródªowe projektu oraz
pliki nagªówkowe, odpowiednio. Wybór tego pola nie jest wymagany. Trzecia opcja pozwala na zachowanie
mody�kacji kodu, jakie wprowadziª ju» programista do kodu programu. Zachowywane s¡ one jedynie, gdy
zostaªy one zapisane wewn¡trz odpowiednich znaczników w postaci komentarzy (jest to jedynie przykªad,
gdy» liczba takich znaczników jest wi¦ksza):

1 /* USER CODE BEGIN 2 */
2

3 // tu ta j powinien zna l e ¹ ¢ s i ¦ kod programisty
4

5 /* USER CODE END 2 */

Ostatnia z pól dotyczy usuwania plików, które w przypadku regeneracji nie ulegn¡ zmianie. Owa opcja
powinna by¢ odznaczona, w przypadku, gdy jest aktywna mo»e prowadzi¢ do nieoczekiwanych zachowa«
podczas kompilacji wynikaj¡cych z braku plików.

Po zaakceptowaniu ustawie« przyst¦pujemy do generowania kodu. Podobnie, jak poprzednim razem
mo»na posªu»y¢ si¦ skrótem klawiszowym Ctrl+Shift+G lub wybra¢ Project → Generate Code. Ope-
racja ta nie powinna trwa¢ dªu»ej ni» kilkana±cie sekund w zale»no±ci od kon�guracji sprz¦towej stacji
roboczej. W efekcie powinien si¦ pojawi¢ komunikat o pomy±lnym wygenerowaniu kodu ¹ródªowego. Ko-
munikat ten nale»y zamkn¡¢ wybieraj¡c przycisk Zamknij (Close). Zawarto±¢ katalogu i jego struktura
po operacji zostaªa pokazana na rysunku 17.
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4.2 Automatyczne generowanie kodu 4 PRACA Z NARZ�DZIEM STM32CUBEMX

Rysunek 17: Struktura i zawarto±¢ drzewa dla przykªadowego projektu
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5 GPIO � cyfrowe wej±cia/wyj±cia ogólnego przeznaczenia

Jednym z podstawowych peryferiów mikrokontrolera s¡ cyfrowe wej±cia/wyj±cia popularnie nazywane
GPIO (General Purpose Input Output). Zazwyczaj wykorzystywane s¡ one do sterowania zewn¦trznymi
ukªadami, które nie wymagaj¡ wyra�nowanych szeregowych protokoªów komunikacyjnych. Ka»dy pin
mo»e dziaªa¢ w jednym z poni»szych trybów:

� wej±cie pªywaj¡ce,

� wej±cie podci¡gni¦te do góry (pull�up),

� wej±cie ±ci¡gni¦te w dóª (pull�down),

� wej±cie analogowe,

� wyj±cie typu otwarty dren (open�drain) z mo»liwo±ci podci¡gni¦cia do góry (pull�up) lub ±ci¡gni¦cia
na dóª (pull�down),

� wyj±cie typu push�pull z mo»liwo±ci podci¡gni¦cia do góry (pull�up) lub ±ci¡gni¦cia na dóª (pull�
down),

� funkcja alternatywna typu otwarty dren z mo»liwo±ci podci¡gni¦cia do góry (pull�up) lub ±ci¡gni¦cia
na dóª (pull�down),

� funkcja alternatywna typu push�pull z mo»liwo±ci podci¡gni¦cia do góry (pull�up) lub ±ci¡gni¦cia
na dóª (pull�down).

Na szczególn¡ uwag¦ zasªuguje tryb analogowy. Nale» tutaj podkre±li¢, »e nie wszystkie wej±cia GPIO
mog¡ by¢ podª¡czone do przetwornika analogowo�cyfrowego ADC. Jednak»e kon�guracja danego pinu
mikrokontrolera w trybie analogowym pozwala na ograniczenie paso»ytniczych pr¡dów. Osi¡ga si¦ to
poprzez wyª¡czenie:

� buforów wyj±ciowych,

� bramki Schitta,

� rezystorów podci¡gaj¡cych/±ci¡gaj¡cych (pull�up/pull�down).

Rysunek 18: Wybór trybu pracy pinu mikrokontrolera

Na rysunku 19 zostaªa przedstawiona przykªadowa kon�guracja siedmiu wybranych pinów mikrokon-
trolera (PA5, PA8, PA9, PA10, PA11, PC9, PC13). Aplikacja STM32CubeMX pozwala na ªatw¡ i przejrzyst¡
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Nazwa pinu Funkcja

PA5 Wyj±cie (dioda LED)
PA8 Wej±cie przerwania zewn¦trznego
PA9 Wyj±cie zdarzenia
PA10 Tryb analogowy
PA11 Wej±cie
PC9 Wyj±cie
PC13 Wej±cie przerwania zewn¦trznego (przycisk)

Tabela 1: Przykªadowa kon�guracja pinów mikrokontrolera

kon�guracj¦ peryferiów ukªadu. Kon�guracja wybranego peryferium odbywa si¦ na jeden z dwóch spo-
sobów. Pierwszym z nich jest wybranie funkcji pinu mikrokontrolera przez klikni¦cie na niego lewym
przyciskiem myszy i wybraniu zadanej funkcjonalno±ci z menu kontekstowego (rys. 18). Taka kon�gura-
cja ma sens w przypadku, gdy b¦dzie wykorzystywany pojedynczy pin, tak jak to ma miejsce w wypadku
kon�guracji GPIO. Druga ze ±cie»ek wymaga w pierwszej kolejno±ci wybrania odpowiedniego peryferium
np. SPI, a wówczas wymagane piny zostan¡ automatycznie przypisane do domy±lnych portów.

Rysunek 19: Przykªadowa kon�guracja wybranych trybów

Jak mo»na zauwa»y¢ na rysunku 19 zostaªo skon�gurowanych a» siedem piny mikrokontrolera. Dwa
z nich dost¦pne s¡ w podstawowej kon�guracji dla pªytki deweloperskiej. S¡ nimi piny PA5, który peªni
funkcj¦ wyj±cia, do którego podª¡czona jest dioda LED oraz PC13, który z kolei wykorzystywany jest jako
wej±cie, do którego podª¡czony jest przycisk. Pozostaªe piny zostaªy skon�gurowane w taki sposób, aby
pokaza¢ peªen wachlarz mo»liwo±ci ukªadu scalonego. Po klikni¦ciu w jeden z wybranych pinów GPIO
rozwija si¦ menu kon�guracyjne, gdzie mo»liwe jest wybranie dodatkowych ustawie« dla aktywnego portu.
S¡ one dostosowywane kontekstowo w zale»no±ci, czy nó»ka mikrokontrolera pracuje, jako wej±cie, wyj±cie,
czy w trybie analogowym.

5.1 GPIO w bibliotece HAL

Do podstawowych funkcji, które pozwalaj¡ na ingerowanie w prac¦ portów GPIO nale»¡ [2]:

� GPIO_PinState HAL_GPIO_ReadPin(GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin),

� void HAL_GPIO_WritePin(GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin, GPIO_PinState

PinState),

� void HAL_GPIO_TogglePin(GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin),
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� void HAL_GPIO_LockPin(GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin),

� void HAL_GPIO_EXTI_IRQHandler (uint16_t GPIO_Pin),

� void HAL_GPIO_EXTI_Callback(uint16_t GPIO_Pin).

HAL_GPIO_ReadPin() pozwala na odczytanie aktualnej warto±ci rejestru wej±ciowego przypisanego do
danego portu. Funkcja przyjmuje dwa parametry. Pierwszym z nich jest port, którego pin ma zosta¢ od-
czytany natomiast drugim parametrem jest numer pinu, którego wywoªanie dotyczy. Warto±ci¡ zwracan¡
jest stan portu, która mo»e przyj¡¢ dwa stany GPIO_PIN_RESET (0), b¡d¹ GPIO_PIN_SET (1).

Mody�kacj¦ stanu wyj±cia portu mo»na wykona¢ poprzez wywoªanie funkcji HAL_GPIO_WritePin().
Przyjmuje ona trzy parametry, gdzie pierwsze dwa s¡ identyczne, jak w przypadku procedury odczytuj¡-
cej, natomiast trzeci z parametrów okre±la »¡dany stan cyfrowego wyj±cia.

W przypadku, gdy wymagane jest przeª¡czenie wyj±cia na przeciwny stan mo»na wykorzysta¢ funkcj¦
HAL_GPIO_TogglePin(). Przeª¡cza ona stan pinu na przeciwny, to jest, z stanu wysokiego na niski i analo-
gicznie z niskiego na wysoki. Parametry wywoªania s¡ identyczne, jak w przypadku HAL_GPIO_ReadPin().

Kolejn¡ funkcj¡, która jest wykorzystywana rzadziej ni» poprzednie jest HAL_GPIO_LockPin(). Zada-
niem funkcji jest zablokowanie rejestrów nale»¡cych do danego pinu mikrokontrolera. W ten sposób po
wywoªaniu operacji zapisu, czy przeª¡czenia stanu na zadanym porcie nie przyniesie ona »adnego efektu.
Mody�kacja stanu zablokowanego portu b¦dzie dopiero mo»liwa pod resecie mikrokontrolera.

Kolejne dwa wywoªania HAL_GPIO_EXTI_IRQHandler() oraz HAL_GPIO_EXTI_Callback() dotycz¡
one obsªugi przerwa« zewn¦trznych, zostan¡ one opisane szczegóªowo pó¹niej.
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6 Zadania do wykonania

6.1 Uzupeªnienie programu o kod odpowiedzialny za miganie diod¡ LED

Biblioteka HAL oferuje szerok¡ gam¦ funkcji wªa±ciwych dla ka»dego z peryferium. W przypadku cy-
frowych portów wej±ciowo�wyj±ciowych ogólnego przeznaczenia (GPIO) mo»na wyró»ni¢ trzy podstawowe
funkcje, których prototypy zostaªy podane poni»ej [2].

1 GPIO_PinState HAL_GPIO_ReadPin (GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin) ;
2

3 void HAL_GPIO_WritePin (GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin , GPIO_PinState PinState ) ;
4

5 void HAL_GPIO_TogglePin (GPIO_TypeDef * GPIOx, uint16_t GPIO_Pin) ;

Funkcje sªu»¡ odpowiednio do: odczytu stanu portu, zapisu stanu portu oraz przeª¡czenia aktywnego
stanu portu na przeciwny. Szczegóªowy ich opis, a tak»e typy wyliczeniowe, jakie s¡ wykorzystywane
w owych funkcjach mo»na znale¹¢ w [2]. Ponadto, STM32CubeMX dostarcza de�nicji nazw portów oraz
pinów, jakie zostaªy nadane przez u»ytkownika w projekcie STM32CubeMX. Maj¡ one posta¢ XXX_Port
oraz XXX_Pin, odpowiednio dla portów i dla pinów. De�nicje te znajduj¡ si¦ w pliku nagªówkowym
main.h, b¡d¹ mxconstants.h

Wykorzystuj¡c podane wy»ej API napisz prosty program, który b¦dzie zapalaª, a nast¦pnie gasiª diod¦
LED podª¡czon¡ do pinu PA5.

Funkcj¡ wprowadzaj¡c¡ aktywne opó¹nienie (tzw. busy�wait) jest

1 void HAL_Delay ( uint32_t Delay ) ;

Przyjmuje ona jako parametr warto±¢ wyra»on¡ w milisekundach [ms].
Uwaga! W przypadku, kiedy funkcja HAL_Delay() nie przynosi efektu nale»y stworzy¢ wªasn¡

funkcj¦ o nazwie delay_ms(). Jej prototyp zostaª podany poni»ej:

1 void delay_ms ( uint32_t ms) {
2 uint32_t i , de lay ;
3 delay = ms * 80000;
4 f o r ( i = 0 ; i < delay ; ) {
5 ++i ;
6 }
7 }

Warto±¢ opó¹nienia nale»y dostosowa¢ na zasadzie obserwacji. Jaki jest powód, »e funkcja
HAL_Delay() nie przynosi oczekiwanego efektu?

Uwaga! Numer portu, jak i pinu, do którego podª¡czona jest dioda LED mo»na odczyta¢ z projektu
w programie STM32CubeMX.

6.2 Wgranie i testowanie programu na mikrokontrolerze

Kolejnym etapem po zaimporotwaniu projektu jest jego zbudowanie. Mo»na to zrobi¢ poprzez wy-
branie polecenia z menu (Project → Build All) lub u»y¢ kombinacji klawiszy Ctrl+B. Budowa projektu
jest czasochªonnym i mo»e zaj¡¢ kilka minut w zale»no±ci od kon�guracji projektu, jaki i od parametrów
stacji roboczej.

Aby wgra¢ oprogramowanie na mikrokontroler nale»y podª¡czy¢ zestaw deweloperski do komputera za
pomoc¡ kabla USB�mini USB. Kolejnym krokiem jest uruchomienie aplikacji STM32 ST-Link Utility

[6], [7]. Widok aplikacji ST-Link zaraz po uruchomieniu zostaª zaprezentowany na rysunku 20.

Wszystkie prawa zastrze»one Wojciech Domski © 2017-2018, edu.domski.pl 19

edu.domski.pl


6.2 Wgranie i testowanie programu na mikrokontrolerze 6 ZADANIA DO WYKONANIA

Rysunek 20: Aplikacja STM32 ST-Link Utility

Otwórz plik binarny (*.bin lub *.hex ) za pomoc¡ polecenia z menu (File→ Open �le ...). Plik binarny
znajduje si¦ wewn¡trz katalogu Debug w gªównej kartotece projektu. Po otwarciu pliku z programem
aplikacja powinna zmieni¢ wygl¡d na podobny do prezentowanego na rysunku 21.

Rysunek 21: ST-Link Utility z otwartym kodem programu

Aby wgra¢ program nale»y wykona¢ trzy operacje:

1. Poª¡czy¢ si¦ z zestawem edukacyjnym wybieraj¡c z menu opcj¦ Poª¡cz (Target → Connect), Rys.
22.

2. Wgra¢ program za pomoc¡ polecenia Programowania i wery�kacji (Target → Program & Verify ...),
Rys. 23.

3. Odª¡czy¢ zestaw ewaluacyjny wybieraj¡c polecenie Rozª¡cz (Target → Disconnect), Rys. 24.
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Uwaga! W przypadku problemów z wgraniem programu na pªytk¦ dewelopersk¡ nale»y upewni¢
si¦, czy system Windows zainstalowaª do niej sterowniki. Instalacja oprogramowania mo»e potrwa¢ okoªo
minuty. Post¦p instalacji mo»na ±ledzi¢ w zasobniku systemowym.

Rysunek 22: Widok aplikacji ST-Link po udanej próbie poª¡czenia z programatorem

Rysunek 23: Widok aplikacji po wczytaniu pliku oraz wybraniu operacji zapisu programu z wery�kacj¡
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Rysunek 24: Widok aplikacji po pomy±lnym wgraniu nowego oprogramowania na mikrokontroler

Po pomy±lnym wgraniu programu dioda u»ytkownika powinna miga¢.
Uwaga! W przypadku, gdy operacja poª¡czenia si¦ nie powiodªa to najprawdopodobniej ukªad

nie zostaª poª¡czony z komputerem za pomoc¡ dostarczonego przewodu USB lub zwory na zª¡czu CN2
nie s¡ zwarte [5]. Innym powodem mo»e by¢ brak zainstalowanych sterowników w systemie. W takim
przypadku nale»y zwery�kowa¢, czy sterowniki te s¡ instalowane, a w tym czasie nie wolno odª¡cza¢
urz¡dzenia (pªytki) od komputera.

6.3 Mody�kacja projektu i programu w celu obsªugi przycisku pracuj¡cego

w roli przeª¡cznika dla diody LED

Jako mody�kacj¦ programu nale»y wykorzysta¢ przycisk znajduj¡cy si¦ na pªycie do zmiany stanu
diody (wª¡czona/wyª¡czona). Innymi sªowy, pojedyncze naci±ni¦cie przycisku powinno zmienia¢ stan
diody. Zmiana stanu diody powinna nast¡pi¢ tylko podczas wciskania przycisku, a nie jego puszczania.
Dodatkowo, w przypadku, gdy przycisk jest trzymany caªy czas stan diody nie powinien si¦ zmienia¢.
Ponadto, w programie nie mo»na wykorzysta¢ opó¹nienia wi¦kszego ni» 10 milisekund.

Zaimplementuj procedur¦ do niwelowania zjawiska drga« styków (tzw. debouncing). Do tego celu
mo»na wykorzysta¢ przerwania, ale nie jest to wymagane. Procedura powinna by¢ tak napisana, aby nie
zatrzymywa¢ wykonywania programu niepotrzebnie. Do tego celu mo»na wykorzysta¢ maªy jednostanowy
automat.

Czy mody�kacja projektu w programie STM32CubeMX jest konieczna? Je±li tak to co nale»y w nim
zmieni¢. Powtórz kroki zwi¡zane z automatycznym generowaniem kodu je±li zajdzie taka potrzeba.

Przydatn¡ funkcj¡ mo»e okaza¢ si¦

1 uint32_t HAL_GetTick ( void ) ;

zwraca ona liczb¦ tików zegara SysTick. Mo»na przyj¡¢, »e jeden tick to 1 milisekunda. Funkcj¦ t¡ warto
wykorzysta¢ podczas implementowania debouncingu.

Uwaga! Numer portu, jak i pinu, do którego podª¡czony jest przycisk mo»na odczyta¢ z projektu
w programie STM32CubeMX.

6.4 Wgranie i testowanie zmody�kowanego programu na mikrokontrolerze

Post¦puj¡c podobnie, jak to zostaªo opisane w sekcji 6.2 nanie± mody�kacje, przebuduj program
(Ctrl+B) oraz wgraj go na pªytk¦ za pomoc¡ narz¦dzia ST-Link Utility.
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6.5 Uporz¡dkowanie stanowiska

Odªó» pªytk¦ i kabel na miejsce. Usu« projekt z Atollic TrueSTUDIO. Mo»na to zrobi¢ przez klikni¦cie
prawym przyciskiem myszki na projekt i wybranie opcji Usu« (Delete) z menu kontekstowego.
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7 Podsumowanie

Poprzez wykonanie ¢wicze« z tej instrukcji zaznajomiªe±(a±) si¦ z podstawowymi narz¦dziami do gene-
rowania i rozwijania oprogramowania dla mikrokontrolera serii STM32L4. Przedstawiono tutaj narz¦dzie
STM32CubeMX, które pozwala na wst¦pne skon�gurowanie peryferiów ukªadu oraz dobór taktowania dla
poszczególnych zespoªów funkcjonalnych mikrokontrolera. Ponadto, STM32CubeMX pozwala na automa-
tyczne generowanie kodu, który mo»e by¢ nast¦pnie mody�kowany. Tak wygenerowane pliki ¹ródªowe
wraz z caªym projektem mog¡ by¢ bez przeszkód zaimportowane do darmowego ±rodowiska programi-
stycznego Atollic TrueSTUDIO for STM32, w którym to wykonuje si¦ edycj¦ kodu ¹ródªowego oraz
kompilacj¦. W ko«cu mo»liwe jest wgranie pliku binarnego na mikrokontroler umieszczony na pªytce
deweloperskiej za po±rednictwem STM32 ST-LINK Utility.
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